Pages

EarnKori Headline Animator

Search This Blog

Jun 10, 2011

How to configure Routing Information Protocol RIP routing

Rip Routing Configurations


In this article I will demonstrate an example of Rip Routingconfigurations. We will use four different series router so you can get familiar with all different platform covered in CCNA exam. Create a topology as shown in figure.


IP RIP comes in two different versions: 1 and 2. Version 1 is a distance vector protocol and is defined in RFC 1058. Version 2 is a hybrid protocol and is defined in RFCs 1721 and 1722. The CCNA exam now primarily focuses on version 2. There are no major differences between RIPv1 or RIPv2 so far configurations concern. To read more about differences between RIPv1 or RIPv2 or know about the characteristics read our pervious article about RIP.




1841 Series Router0 (R1)

FastEthernet0/0Serial0/0/0
IP address10.0.0.120.0.0.1
Connected WithPc0R2 on Serial 0/0
2811 Series Router0 (R4)

FastEthernet0/0Serial0/0/0
IP address50.0.0.140.0.0.2
Connected WithPc1R3 on Serial 0/0
2621XM Series Router0 (R3)

FastEthernet0/0Serial0/0/0
IP address30.0.0.240.0.0.1
Connected WithFastEthernet0/0R4 on Serial 0/0/0
2620XM Series Router1 (R2)

FastEthernet0/0Serial0/0
IP address30.0.0.120.0.0.2
Connected WithR3 on FastEthernet0/0R1 on Serial 0/0/0
PC-PT PC0

FastEthernet0Default Gateway
IP address10.0.0.210.0.0.1
Connected WithR1 on FastEthernet0/0
PC-PT PC1

FastEthernet0Default Gateway
IP address50.0.0.250.0.0.1
Connected WithR4 on FastEthernet0/0

To configure any router double click on it and select CLI. To configure this topology use this step by step guide.

 

(1841Router0) Hostname R1

To configure and enable rip routing on R1 follow these commands exactly. 

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#interface serial 0/0/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#bandwidth 64
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
R1(config-if)#exit
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit
R1(config)#

 

(2620XM-Router1) Hostname R2

To configure and enable rip routing on R2 follow these commands exactly. 


Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface serial 0/0
R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R2(config-if)#exit
R2(config)#interface fastethernet 0/0
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
R2(config-if)#exit
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config)#router rip
R2(config-router)#network 20.0.0.0
R2(config-router)#network 30.0.0.0
R2(config-router)#exit
R2(config)#


(2620XM-Router2)Hostname R3

To configure and enable rip routing on R3 follow these commands exactly. 

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R3
R3(config)#interface fastethernet 0/0
R3(config-if)#ip address 30.0.0.2 255.0.0.0
R3(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R3(config-if)#interface serial 0/0
R3(config-if)#ip address 40.0.0.1 255.0.0.0
R3(config-if)#clock rate 64000
R3(config-if)#bandwidth 64
R3(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to down
R3(config-if)#exit
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R3(config)#router rip
R3(config-router)#network 30.0.0.0
R3(config-router)#network 40.0.0.0
R3(config-router)#exit
R3(config)#

(2811Router3) Hostname R4

To configure and enable rip routing on R4 follow these commands exactly. 

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface serial 0/0/0
Router(config-if)#ip address 40.0.0.2 255.0.0.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
Router(config-if)#exit
Router(config)#interface fastethernet 0/0
Router(config-if)#ip address 50.0.0.1 255.0.0.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
R4(config)#router rip
R4(config-router)#network 40.0.0.0
R4(config-router)#network 50.0.0.0
R4(config-router)#exit
R4(config)#

PC-1


PC>ipconfig

IP Address......................: 10.0.0.2
Subnet Mask.....................: 255.0.0.0
Default Gateway.................: 10.0.0.1

PC>ping 50.0.0.2

Pinging 50.0.0.2 with 32 bytes of data:

Reply from 50.0.0.2: bytes=32 time=156ms TTL=124
Reply from 50.0.0.2: bytes=32 time=127ms TTL=124
Reply from 50.0.0.2: bytes=32 time=156ms TTL=124
Reply from 50.0.0.2: bytes=32 time=140ms TTL=124

Ping statistics for 50.0.0.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 127ms, Maximum = 156ms, Average = 144ms
PC>


PC-2

PC>ipconfig

IP Address......................: 50.0.0.2
Subnet Mask.....................: 255.0.0.0
Default Gateway.................: 50.0.0.1

PC>ping 10.0.0.2

Pinging 10.0.0.2 with 32 bytes of data:

Reply from 10.0.0.2: bytes=32 time=140ms TTL=124
Reply from 10.0.0.2: bytes=32 time=141ms TTL=124
Reply from 10.0.0.2: bytes=32 time=157ms TTL=124
Reply from 10.0.0.2: bytes=32 time=156ms TTL=124

Ping statistics for 10.0.0.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 140ms, Maximum = 157ms, Average = 148ms
You can verify that RIP is running successfully via show ip protocols command in privilege mode. 

R1#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 2 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
  Interface             Send  Recv  Triggered RIP  Key-chain
  FastEthernet0/0       1     2 1
  Serial0/0/0           1     2 1
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
 10.0.0.0
 20.0.0.0
Passive Interface(s):
Routing Information Sources:
 Gateway         Distance      Last Update
 20.0.0.2             120      00:00:20
Distance: (default is 120)
R1#
You can use show ip route command to troubleshoot rip network. If you did not see information about any route checks the router attached with that network. 

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    10.0.0.0/8 is directly connected, FastEthernet0/0
C    20.0.0.0/8 is directly connected, Serial0/0/0
R    30.0.0.0/8 [120/1] via 20.0.0.2, 00:00:01, Serial0/0/0
R    40.0.0.0/8 [120/2] via 20.0.0.2, 00:00:01, Serial0/0/0
R    50.0.0.0/8 [120/3] via 20.0.0.2, 00:00:01, Serial0/0/0
R1#
To test rip routing do ping from pc1 to pc2 and vice versa. If you get replay then you have successfully configured rip routing but if you did not get replay double check this configuration and try to troubleshoot. I have uploaded a configured and tested topology in case you are unable to locate the problem spot then download this configuration file. And try to find out where have you committed mistake.


CommandsDescriptions
Router(config)#router ripEnables RIP as a routing protocol
Router(config-router)#network w.x.y.zw.x.y.z is the network number of the directly connected network you want to advertise.
Router(config)#no router ripTurns off the RIP routing process
Router(config-router)#no network w.x.y.zRemoves network w.x.y.z from the RIP routing process.
Router(config-router)#version 2RIP will now send and receive RIPv2 packets globally.
Router(config-router)#version 1RIP will now send and receive RIPv1 packets only
Router(config-router)#no auto-summaryRIPv2 summarizes networks at the classful boundary. This command turns autosummarization off.
Router(config-router)#passive-interface s0/0/0RIP updates will not be sent out this interface.
Router(config-router)#no ip split-horizonTurns off split horizon (on by default).
Router(config-router)#ip split-horizonRe-enables split horizon
Router(config-router)#timers basic 30 90 180 270 360Changes timers in RIP: 30 = Update timer (in seconds) 90 = Invalid timer (in seconds) 180 = Hold-down timer (in seconds) 270 = Flush timer (in seconds) 360 = Sleep time (in milliseconds)
Router#debug ip ripDisplays all RIP activity in real time
Router#show ip rip databaseDisplays contents of the RIP database

No comments: